Upgrade to flutter 2 with snapd

Hello, I want to upgrade flutter 1.22 to flutter 2 the latest stable release.
I am using snapd.
When I run the command sudo snap refresh flutter I get this error:
snap "flutter" has no updates available.

How to update flutter?