I can't build flutter apps in IOS

Hi,

I’m with Mac book air M1 2020.

I installed flutter/Android/Xcode. So, my flutter doctor is :

Doctor summary (to see all details, run flutter doctor -v):

[✓] Flutter (Channel stable, 2.2.3, on macOS 11.4 20F71 darwin-arm, locale

fr-MG)

[✓] Android toolchain - develop for Android devices (Android SDK version 30.0.3)

[✓] Xcode - develop for iOS and macOS

[✓] Chrome - develop for the web

[✓] Android Studio (version 4.0)

[✓] VS Code (version 1.58.0)

[✓] Connected device (2 available)

After run my app with : flutter run, I have this problem:

LoadError - dlopen(/Users/eugenepatrice/.gem/ruby/2.6.0/gems/ffi-1.15.3/lib/ffi_c.bundle, 9): no suitable image found. Did find:
/Users/eugenepatrice/.gem/ruby/2.6.0/gems/ffi-1.15.3/lib/ffi_c.bundle: mach-o, but wrong architecture
/Users/eugenepatrice/.gem/ruby/2.6.0/gems/ffi-1.15.3/lib/ffi_c.bundle: mach-o, but wrong architecture - /Users/eugenepatrice/.gem/ruby/2.6.0/gems/ffi-1.15.3/lib/ffi_c.bundle
/Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:85:in require' /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:85:in require’
/Users/eugenepatrice/.gem/ruby/2.6.0/gems/ffi-1.15.3/lib/ffi.rb:5:in rescue in <top (required)>' /Users/eugenepatrice/.gem/ruby/2.6.0/gems/ffi-1.15.3/lib/ffi.rb:2:in <top (required)>’
/Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:85:in require' /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:85:in require’
/Library/Ruby/Gems/2.6.0/gems/ethon-0.14.0/lib/ethon.rb:3:in <top (required)>' /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:85:in require’
/Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:85:in require' /Library/Ruby/Gems/2.6.0/gems/typhoeus-1.4.0/lib/typhoeus.rb:2:in <top (required)>’
/Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:85:in require' /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:85:in require’
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/sources_manager.rb:74:in cdn_url?' /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/sources_manager.rb:36:in create_source_with_url’
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/sources_manager.rb:21:in find_or_create_source_with_url' /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/installer/analyzer.rb:178:in block in sources’
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/installer/analyzer.rb:177:in map' /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/installer/analyzer.rb:177:in sources’
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/installer/analyzer.rb:1073:in block in resolve_dependencies' /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/user_interface.rb:64:in section’
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/installer/analyzer.rb:1072:in resolve_dependencies' /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/installer/analyzer.rb:124:in analyze’
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/installer.rb:414:in analyze' /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/installer.rb:239:in block in resolve_dependencies’
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/user_interface.rb:64:in section' /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/installer.rb:238:in resolve_dependencies’
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/installer.rb:160:in install!' /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/command/install.rb:52:in run’
/Library/Ruby/Gems/2.6.0/gems/claide-1.0.3/lib/claide/command.rb:334:in run' /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/lib/cocoapods/command.rb:52:in run’
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.10.1/bin/pod:55:in <top (required)>' /usr/local/bin/pod:23:in load’
/usr/local/bin/pod:23:in `’

My Gem list :

*** LOCAL GEMS ***

abbrev (default: 0.1.0)

base64 (default: 0.1.0)

benchmark (default: 0.1.1)

bigdecimal (default: 3.0.0)

bundler (2.2.24, default: 2.2.22)

cgi (default: 0.2.0)

csv (default: 3.1.9)

date (default: 3.1.0)

dbm (default: 1.1.0)

debug (default: 0.1.0)

delegate (default: 0.2.0)

did_you_mean (default: 1.5.0)

diff-lcs (1.4.4)

digest (default: 3.0.0)

drb (default: 2.0.4)

english (default: 0.7.1)

erb (default: 2.2.0)

etc (default: 1.2.0)

fcntl (default: 1.0.0)

ffi (1.15.3)

fiddle (default: 1.0.6)

fileutils (default: 1.5.0)

find (default: 0.1.0)

forwardable (default: 1.3.2)

getoptlong (default: 0.1.1)

io-console (default: 0.5.7)

io-nonblock (default: 0.1.0)

io-wait (default: 0.1.0)

ipaddr (default: 1.2.2)

irb (default: 1.3.5)

json (default: 2.5.1)

kramdown (2.3.1)

logger (default: 1.4.3)

matrix (default: 0.3.1)

minitest (5.14.2)

mutex_m (default: 0.1.1)

net-ftp (default: 0.1.2)

net-http (default: 0.1.1)

net-imap (default: 0.1.1)

net-pop (default: 0.1.1)

net-protocol (default: 0.1.0)

net-smtp (default: 0.2.1)

nkf (default: 0.1.0)

observer (default: 0.1.1)

open-uri (default: 0.1.0)

open3 (default: 0.1.1)

openssl (default: 2.2.0)

optparse (default: 0.1.0)

ostruct (default: 0.3.1)

pathname (default: 0.1.0)

power_assert (1.2.0)

pp (default: 0.1.0)

prettyprint (default: 0.1.0)

prime (default: 0.1.2)

pstore (default: 0.1.1)

psych (default: 3.3.0)

racc (default: 1.5.1)

rake (13.0.6, 13.0.3)

rake-compiler (1.0.9)

rake-compiler-dock (1.1.0)

rbs (1.0.4)

rdoc (default: 6.3.1)

readline (default: 0.0.2)

readline-ext (default: 0.1.1)

reline (default: 0.2.5)

resolv (default: 0.2.0)

resolv-replace (default: 0.1.0)

rexml (3.2.5)

rinda (default: 0.1.0)

rspec (3.10.0)

rspec-core (3.10.1)

rspec-expectations (3.10.1)

rspec-mocks (3.10.2)

rspec-support (3.10.2)

rss (0.2.9)

securerandom (default: 0.1.0)

set (default: 1.0.1)

shellwords (default: 0.1.0)

singleton (default: 0.1.1)

stringio (default: 3.0.0)

strscan (default: 3.0.0)

syslog (default: 0.1.0)

tempfile (default: 0.1.1)

test-unit (3.3.7)

time (default: 0.1.0)

timeout (default: 0.1.1)

tmpdir (default: 0.1.2)

tracer (default: 0.1.1)

tsort (default: 0.1.0)

typeprof (0.12.0)

un (default: 0.1.0)

uri (default: 0.10.1)

weakref (default: 0.1.1)

yaml (default: 0.1.1)

yard (0.9.26)

zlib (default: 1.1.0)

Thank for help me!

:slight_smile: