Hot-reload not working!

Guys, after upgrading flutter, the hot-reload stoped working. I’m getting this message: ‘Error running hot-reload: type ‘LocalDirectory’ is not a subtype of type ‘File’’’

Does anybody know how to work around it?

Thanks in advance

#hotreload #hot #reload

2 Likes

Can you please share the old/new version. I think these kind of reports should go to github issues.
I would suggest you create an issue on repo.

Just figured out what was happening. The problem is related with the versions available at Flutter Master Channel. To fix the hot-load problem I just had to rollback to the Stable Channel.

thanks

1 Like

That’s great! I am sure it will help someone else too.