Getting build errors with Flutter Notification Plugin

When I am using Flutter Local Notification Plugin (4.0.1), I am getting build errors on both Android and iOS. This is occurring with few other plugins as well - Apple Sign in for iOS and Google Maps APis. However, the builds are successful when these plugins are disabled. Would appreciate any help or direction on how to go about resolving these issues.

Here’s the error log:

  • What went wrong:
    Execution failed for task ‘:app:checkDebugAarMetadata’.

Could not resolve all files for configuration ‘:app:debugRuntimeClasspath’.
Could not resolve androidx.media:media:1.1.0.
Required by:
project :app > project :flutter_local_notifications
Could not resolve androidx.media:media:1.1.0.
Could not get resource ‘https://dl.google.com/dl/android/maven2/androidx/media/media/1.1.0/media-1.1.0.pom’.
Could not GET ‘https://dl.google.com/dl/android/maven2/androidx/media/media/1.1.0/media-1.1.0.pom’.
The server may not support the client’s requested TLS protocol versions: (TLSv1.2). You may need to configure the client to allow other protocols to be used. See: https://docs.gradle.org/6.8.2/userguide/build_environment.html#gradle_system_properties
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target