FlutterSomePackagePlugin.java uses or overrides a deprecated API

This problem given two solutions changing minSdkVersion to 23 and setting multiDexEnabled to true, on the internet but none worked for me,

when I run flutter run --no-sound-null-safety I get this error

Note: C:\src\flutter\.pub-cache\hosted\pub.dartlang.org\firebase_core-1.7.0\android\src\main\java\io\flutter\plugins\firebase\core\FlutterFirebaseCorePlugin.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: C:\src\flutter\.pub-cache\hosted\pub.dartlang.org\cloud_firestore-2.5.3\android\src\main\java\io\flutter\plugins\firebase\firestore\FlutterFirebaseFirestorePlugin.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: C:\src\flutter\.pub-cache\hosted\pub.dartlang.org\cloud_firestore-2.5.3\android\src\main\java\io\flutter\plugins\firebase\firestore\streamhandler\TransactionStreamHandler.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: C:\src\flutter\.pub-cache\hosted\pub.dartlang.org\geocoder-0.2.1\android\src\main\java\com\aloisdeniel\geocoder\GeocoderPlugin.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: C:\src\flutter\.pub-cache\hosted\pub.dartlang.org\google_maps_flutter-2.0.9\android\src\main\java\io\flutter\plugins\googlemaps\Convert.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: C:\src\flutter\.pub-cache\hosted\pub.dartlang.org\google_maps_flutter-2.0.9\android\src\main\java\io\flutter\plugins\googlemaps\TileProviderController.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Note: C:\src\flutter\.pub-cache\hosted\pub.dartlang.org\libphonenumber-2.0.2\android\src\main\java\com\codeheadlabs\libphonenumber\LibphonenumberPlugin.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use or override a deprecated API.                
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use or override a deprecated API.                
Note: Recompile with -Xlint:deprecation for details.
Running Gradle task 'assembleDebug'...                                  
Running Gradle task 'assembleDebug'... Done                       190.1s
√  Built build\app\outputs\flutter-apk\app-debug.apk.
Installing build\app\outputs\flutter-apk\app.apk...                 9.4s
D/FlutterLocationService(28465): Creating service.
D/FlutterLocationService(28465): Binding to location service.
Syncing files to device SM A207F...                                272ms

but the package build on my phone.

the packages which are deprecated are already in their latest versions

this is pubspec.yml

version: 1.0.0+1

environment:
  sdk: ">=2.12.0 <3.0.0"

dependencies:
  flutter:
    sdk: flutter


  # The following adds the Cupertino Icons font to your application.
  # Use with the CupertinoIcons class for iOS style icons.
  cupertino_icons: ^1.0.2
  flutter_spinkit: ^5.1.0
  shared_preferences: ^2.0.6
  http: ^0.13.3
  percent_indicator: ^3.0.1
  js: ^0.6.3
  flutter_google_places: ^0.3.0
  intl: ^0.17.0
  google_maps_webservice: ^0.0.20-nullsafety.5
  progress_indicators: ^1.0.0
  smooth_star_rating: ^1.1.1
  email_validator: ^2.0.1
  dropdown_search: ^1.0.3
  intl_phone_number_input: ^0.7.0+2
  pinput: ^1.2.0
  stripe_payment: ^1.1.4
  flutter_html: ^2.1.0
  location: ^4.3.0
  google_maps_flutter: ^2.0.9
  firebase_database: ^8.0.0
  firebase_core: ^1.7.0
  cloud_firestore: ^2.5.3
  dio: ^4.0.0
  flutter_polyline_points: ^1.0.0
  geocoder: ^0.2.1
  table_calendar: ^3.0.2
  url_launcher: ^6.0.10
dev_dependencies:
  flutter_test:
    sdk: flutter

enabling multidex could not solve my problem.

this is android/app/build.gradle

def localProperties = new Properties()
def localPropertiesFile = rootProject.file('local.properties')
if (localPropertiesFile.exists()) {
    localPropertiesFile.withReader('UTF-8') { reader ->
        localProperties.load(reader)
    }
}

def flutterRoot = localProperties.getProperty('flutter.sdk')
if (flutterRoot == null) {
    throw new GradleException("Flutter SDK not found. Define location with flutter.sdk in the local.properties file.")
}

def flutterVersionCode = localProperties.getProperty('flutter.versionCode')
if (flutterVersionCode == null) {
    flutterVersionCode = '1'
}

def flutterVersionName = localProperties.getProperty('flutter.versionName')
if (flutterVersionName == null) {
    flutterVersionName = '1.0'
}

apply plugin: 'com.android.application'
apply plugin: 'kotlin-android'
apply from: "$flutterRoot/packages/flutter_tools/gradle/flutter.gradle"
apply plugin: 'com.google.gms.google-services'

android {
    compileSdkVersion 30

    sourceSets {
        main.java.srcDirs += 'src/main/kotlin'
    }

    defaultConfig {
        // TODO: Specify your own unique Application ID (https://developer.android.com/studio/build/application-id.html).
        applicationId "com.tingsapp.customers"
        minSdkVersion 23
        targetSdkVersion 30
        versionCode flutterVersionCode.toInteger()
        versionName flutterVersionName
    }

    buildTypes {
        release {
            // TODO: Add your own signing config for the release build.
            // Signing with the debug keys for now, so `flutter run --release` works.
            signingConfig signingConfigs.debug
        }
    }
}

flutter {
    source '../..'
}

dependencies {
    implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
    implementation 'com.google.guava:guava:27.0.1-android'
    implementation 'com.google.firebase:firebase-analytics'
}

this is flutter doctor

PS C:\Users\amu\Desktop\projects\mobile apps\tingsapp-customer\customer> flutter doctor
Doctor summary (to see all details, run flutter doctor -v):
[√] Flutter (Channel stable, 2.2.2, on Microsoft Windows [Version 10.0.19041.1165], locale en-US)
[!] Android toolchain - develop for Android devices (Android SDK version 31.0.0)
    ! Some Android licenses not accepted.  To resolve this, run: flutter doctor --android-licenses
[√] Chrome - develop for the web
[√] Android Studio (version 4.0)
[√] VS Code (version 1.61.1)
[√] Connected device (3 available)

! Doctor found issues in 1 category.

this is flutter --version

PS C:\Users\amu\Desktop\projects\mobile apps\tingsapp-customer\customer> flutter --version
Flutter 2.2.2 • channel stable • https://github.com/flutter/flutter.git
Framework • revision d79295af24 (4 months ago) • 2021-06-11 08:56:01 -0700
Engine • revision 91c9fc8fe0
Tools • Dart 2.13.3

any helps please,