Flutter pub upgrade

I am still wondering why i cannot upgrade everything ?
What do I need to do to be able to use latest versions of packages ?

Showing outdated packages.
[*] indicates versions that are not the latest available.

Package Name Current Upgradable Resolvable Latest

direct dependencies:
json_serializable *4.1.4 *4.1.4 *4.1.4 5.0.0

dev_dependencies: all up-to-date.

transitive dependencies:
_fe_analyzer_shared *22.0.0 *22.0.0 *22.0.0 25.0.0
analyzer *1.7.1 *1.7.1 *1.7.1 2.2.0
async *2.6.1 *2.6.1 *2.6.1 2.8.2
charcode *1.2.0 *1.2.0 *1.2.0 1.3.1
json_annotation *4.0.1 *4.0.1 *4.0.1 4.1.0
meta *1.3.0 *1.3.0 *1.3.0 1.7.0
source_gen *1.0.3 *1.0.3 *1.0.3 1.1.0

transitive dev_dependencies:
matcher *0.12.10 *0.12.10 *0.12.10 0.12.11
test_api *0.3.0 *0.3.0 *0.3.0 0.4.3
You are already using the newest resolvable versions listed in the ‘Resolvable’ column.
Newer versions, listed in ‘Latest’, may not be mutually compatible.